Первый звонок всегда обрывается

Первый звонок всегда обрывается

Сообщение Denis » 05 фев 2015, 07:51

Добрый день.

Мы начали использовать программу автообзвона и выяснилось странное - первый звонок всегда обрывается. Потом снова нажимаем Старт и все идет нормально.
Разница по логам в этом моменте:
первый раз
05.02.2015 10:26:45.276 [Событие: 513 - "Начало анализа голосового ответа"]
05.02.2015 10:26:45.276 Начало получения звуковых данных
05.02.2015 10:26:45.276 Послано: AT+VRX<cr>
05.02.2015 10:26:45.677 Получено: <cr><lf>CONNECT<cr><lf>
05.02.2015 10:26:45.677 Начало получения звуковых данных
05.02.2015 10:26:46.170 Завершение получения звуковых данных
05.02.2015 10:26:46.170 Послано: <dle>!
05.02.2015 10:26:46.232 Получено: <dle><etx><cr><lf>OK<cr><lf>
05.02.2015 10:26:46.232 Получение звуковых данных успешно завершено
05.02.2015 10:26:46.232 Анализ голосового ответа завершен
05.02.2015 10:26:46.232 [Событие: 514 - "Анализ голосового ответа завершен"]
05.02.2015 10:26:46.232 Вывод стэка анализа голосового ответа
05.02.2015 10:26:46.232 Состояние устройства изменено с 0083 на 0003
05.02.2015 10:26:46.232 [Событие: 514 - "Ожидание голосового ответа завершено"]
05.02.2015 10:26:46.232 Произошло исключение: 40044, Звонок не удался. :


последующие разы
05.02.2015 10:27:00.596 [Событие: 513 - "Начало анализа голосового ответа"]
05.02.2015 10:27:00.596 Начало получения звуковых данных
05.02.2015 10:27:00.596 Послано: AT+VRX<cr>
05.02.2015 10:27:00.997 Получено: <cr><lf>CONNECT<cr><lf>
05.02.2015 10:27:00.997 Начало получения звуковых данных
05.02.2015 10:27:00.997 N (0 Гц, 0,00)
05.02.2015 10:27:00.997 N (0 Гц, 0,00)
05.02.2015 10:27:00.997 N (0 Гц, 0,00)


Впрочем, еще одно отличие, что при последующих звонках модем перестает повторять переданную ему команду при ответе
05.02.2015 10:26:35.613 Послано: ATI<cr>
05.02.2015 10:26:35.674 Получено: ATI<cr><cr><lf>56000<cr><lf>OK<cr><lf>


05.02.2015 10:26:51.565 Послано: ATI<cr>
05.02.2015 10:26:51.626 Получено: <cr><lf>56000<cr><lf>OK<cr><lf>
Denis
 
Сообщений: 22
Зарегистрирован: 16 янв 2015, 14:22

Re: Первый звонок всегда обрывается

Сообщение Jugin » 05 фев 2015, 12:25

Здравствуйте,
Судя по журналу, программа не получила от модема голосовых данных сразу после включения режима получения голосовых данных. К сожалению, с голосовыми модемами такое бывает. Эта технология уже давно уходит с рынка, уступая VoIP, поэтому качество работы модемов, особенно в голосовых режимах, падает, да и в общем то всегда было невысоким.
Команда ATI - это просто команда получения информации о модеме и в вашем случае не должна оказывать никакого влияния на работу в голосовом режиме.
Советую использовать IP-телефонию, наш продукт позволяет с ней работать. Если все же у Вас есть желание разобраться и заставить работать ваш модем, можем включить расширенную диагностику, постараться точно выяснить, в чем именно проблема и, возможно, найти решение.
Jugin
Администратор
 
Сообщений: 33
Зарегистрирован: 20 ноя 2012, 12:19
Откуда: Россия, Барнаул


Вернуться в Голосовые модемы

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron